Acromag|yq

APPLICATION NOTE

Configuring Omron CJ2H PLC’s with
Ethernet/IP for use with Acromag
Ethernet/IP Remote I/O

ACROMAG INCORPORATED Tel: (Process): (248) 295-0880
30765 South Wixom Road Fax: (248) 624-9234
P.O. BOX 437

Wixom, MI 48393-7037 U.S.A.

Copyright 2010, Acromag, Inc., Printed in the USA.
Data and specifications are subject to change without notice. 8500-883-10C000



2 Acromag Ethernet/IP 1/0 with Omron CJ2H PLC’s App Note

OBJECTIVE This document walks the user through the configuration of the Cx-One
Network Configurator software that is used in conjunction with Omron CJ2H
PLC’s. It is assumed that the user has a working knowledge of the PLC and
Cx-One software.
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Configuring the Cx-
One “Network
Configurator”

1. Start the Cx-One Network
Configurator by selecting
Start-> All Programs-
>0Omron-> Cx-One->
Network Configurator for
Ethernet/IP-> Network
Configurator.

2. Expand the
Communications
Adapter tree and double
click on CJ2B-EIP21. The
PLC will be loaded into the
Ethernet/IP_1 window.
Highlight the PLC as
shown, right click on it and
select Change Node
Address.
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3. In this box, enter the IP ;
Address of the PLC and Change IP Address f'5__<|
then click OK.

Mew P Address: | 172 . 16 . 40 . 21

] l [ Cancel

4. Click on EDS Files-

>Install in the main Install EDS File @
window to bring up this - » Cw

dialog box. Navigate to Lei | (2 Desktop v| S (3~

where the EDS files are ID[‘-’I*;f Documents [|953eneip, ads

stored on your system and J My Computer

then double click on the 8 "V -omp

model being installed. Sd0ty Netwiork Places
I3 C-0ne Introduction Guide Library
|- visual Studio 2005

Iy ICUsEZ32
File narme: |E|BSeneip | [ Open l
Files af ype: | Electronic Data Sheet[. eds) w | [ Cancel ]

Device |nformation
Yendor: Acromag, (.
Device Type : Genernc Device
Product Mame : Acromag 383EM-6012
Rewvizion: 1.01

5. Click on No when it asks if . 7
the icon should be Metwork Configurator 4

installed.
\?/ Install the Icon of Acromag 933EM-60127
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£ Untitled - Network Configurator 6. The Acromag device has
File Edic View MNebwork Device EDSFile Tools Option  Help now been added to the
Led 2 g & X |[22) Communications Adapter
B W & | @ Y tree, double click on it to
= * (7 Etherhet/IP_1 add it to the Ethern et/IP_l
=3 A . .
g = e Device ° = network window. Then
P, Cﬂcmmal_s S3EN-6C i e right click on the Acromag
=% Urnron Lorporation .
2 o Communications Adapts 172164021 device and select Change
=[] CHw-EIP2T CIzB-EIP21 Node Add
Fev1 B & ode ress.
E Rewv 2
E CIW-EIPZ1(CI2) Uszage of Device Bandwidth
E) CIBEIR21
=B CSTW-EIP21 s
S | &
x Meszage Code Date Description
Feady L:EtherMet/IP|  T:Unknown ©MRO:TOOLBUS — CJ2-CPUxx 115200 Bitfs| @0 Off-line
[‘5—< 7. In this box, enter the IP
e e
Change IP Address _| Address of the Acromag

device and then click OK.

Mew P Addresz: | 172 . 16 . 40 . 100

] l [ Cancel
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8. Double click on the PLC to
bring up the Edit Device
Parameters dialog box at
the right. Then click on the
Down arrow to move the
Acromag device from the
Unregister Device List to
the Register Device List
as shown below.

9. Click on the Tag Sets tab
to bring up the next
window.

Edit Device Parameters

 Connections | Tag Sets|

Unregister Device Lizt

t
P 1721640100

Product Mame

Acromag

Register Dewvice List

Connections . 04206 [0: 0, T :

Product Mame

Edit Device Parameters

 Connections | Tag Sets|

172.16.40.21 CJZB-EIP21 Y ariable Target Yariable

Unregister Device List

#

Product M ame

Register Device List

Connections: 0/256(0:0.T:0)

[+] =

Froduct Mame
P 1172 16.40.100 (#100) &

Target Variable

172.16.40.21 CJZB-EIP21 Variable

Mew... Edit...

Delete Edital.. | [ Change TargetNodeD.. | | TofFomFie |

’ (]9 ][ Cancel ]
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10. Click on the Edit Tags
button to display the Edit

Edit Device Parameters

Connections | Tag Sets | Tags dialog box.
In - Consume | Qut - Produce |
Marne Over.. Size Bit 1D
MHew... Edit... Delete Expand Al LCollapze Al
[ Edit Tags... l [ Delete all of unused Tag Sets | |sage Count: 0/256 ’ Import ] ’ TaoFrom File ]
[ (]9 ] [ Cancel ]
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11. Click on In-Consume tab Edit Tags [5__<|
and then the New button -
to create a tag. In - Corsume: | Dut - Produce
M arne Over.. Size Bit
Hew... Edit... Delete
Jzage count ;04256 [ 0Ok, l [ Cancel ]
12. Enter 5000 for the Name, Edit Tag X

adjust the Size according
to the device and click the . [500g
Regist button and then the a3 | |

Close button. This is the _ —
Tag, name that the Size Byte

Acromag inputs will be [ Usze Bit Drata
identified with inside the
PLC.
Ower Load
Dizable Enahble
Regist ] [ Cloze
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. ' 13. Now click on the Out-
Edit Tags [5__<| Produce tab and repeat
e e —— steps 11 and 12 to create
In - Conzume | Out - Froduce | the output tag using the
: : Name 5100 as shown
M arne Over... Size Bit below..

Edit... Delete

lzage count ;. 1/256 [

]9 l[ Cancel ]

Edit Tag X
Mame : |5'I oo |
Size Byte
[]Uze Bit Data
Ower Load
() Dizable {(*) Enable
[ Regist ] [ Cloze ]
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Edit Tags X
I - Cansume | Qut - Produce
M anne Ower... Size Bit
¥=15000 2Byte
13. The In-Consume and
Out-Produce tabs of the ’ b_<
Edit Tags dialog box Edit Tags _|
should now look like those _
at the right. In - Cansume | Out - Frduse |
M amne Ower... Size Bit
¥=15100 Enable 2Bute

14. Click the OK button of the
Edit Tags box to accept
the crated tags and then
click Yes on the box below

| New. || Edt. || Delste |

lzage count ;. 2/256 |

] |[ Cancel ]

Metwork Configurator

L] E The new Tags will be registered as Tag sets,
L

[ ves | [ Mo
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Edit Device Parameters

| Bomnections | TagSets |

In - Consume | Dlut - Produce |

Mame Over... Size
5000 ZByte

Edit Device Parameters

Bit D
Auto

Connections | Tag Sets |

It - Comsume | Dut - Produce |

MHame Over... Size
& 5100 2Byte

Edit Device Parameters

Bit D
Auto

 Connections | Tag Sets|

Unregister Device List

# Product M ame

P

Connections: 0/256(0:0.T:0)
Register Device List

172.16.40.21 CJZB-EIP21 Variable

Target Variable

Froduct Mame
P 0172 16.40.100 [H100] 4.

Hew... Ed... Delete Edital.. | [ Change Target Node D... |

[ TofFomFie |

(]9 ][ Cancel ]

15.

16.

Click on the In-
Consume and Out-
Produce tabs to verify
that the tags have
been correctly entered
as seen here.

Click on the
Connections tab and
then Double click on
the Acromag Node in
the Register Device
List to bring up the
Edit Connection
window.
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17. Enter a Connection 172.16.40.100 Acromag 983EN-6012 Edit Connection
Name. The Connection
I/O Type, the In put from I:Dnnectign Name: ‘983EN_ED12 |
Tar.get Device Produce Connection 1/0 Type : |E|83EN v|
Variable, the Output to
Target Device Consume Packet Interval [RF1] 20000 s (05 - 10000.0 me )
Variable and the Timeout Value: | Packet Interval (AF1) « 15 v|

Connection Type fields
will all be pre-populated
from the EDS file. Set the Canzurne W ariable : |5EIDEI - [2Bwte] v|
RPI and Timeout Value
as needed, a minimum of
200mS and a RPIx16 is Connection Type : |Multi-ca$t connechion A
recommended as a
starting point for Acromag
Devices. For the Input
From Target Device Praduce Variable : | i EEE
Consume Variable and
the Output to Target
Device Produce Connection Tepe : |F'|:|int ta Paint connection w
Variable, select the tags
you created earlier. Click

Input from T arget Device

Praduce W ariable : | Input_100 - [2Bute] i |

Output to Target Device

Consurne Yariable : | Output_112 - [2Byte] w

) Originator Device Target Device
Regist and then Close
when finished Mode Address : 172.16.40.21 Mode Addresz: 172.16.40.100
Comment : CI2B-EIP21 Comment : Acromag 983EM-6012

Reqizt ] ’ Cloze
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Edit Device Parameters

Cormeciion |yelors

Unregister Device List

# Product M ame

Connectionz: 2/256(0:2.T7:0)
Register Device List

P

Product Mame

. 40,100 [#100) A,

g JFIEMN_G012 [Input] 50
983EM_G012 [Output] 51

172.16.40.21 CJZB-EIP21 Variable

] |

Target Variable

nput_100

oo Output_112

Mew... Edit...

Delate

Edital.. | [ Change Target Node D... |

[ TofFomFie |

(]9 ][ Cancel ]

& Untitled - Network Configurator

File Edit Wiew Metwork Device EDS File

O E 2 &

x
@ Metwork Configurator ~
=) @ EtherNet/IP Hardware J
=] @ Wendor
= Acromag, Inc.
= ﬁ Generic Device

=
LRI I . &

Tools  Option  Help

& || &8

S 4 EBE X [t

@ Ethertiet/ip_t

Change Mode Address...

Change Device Comment...

Download Parame  L:EtherNet/IP  T:EtherNet/IP

QMR

Swnrhrnnize Trirntibe

e Parameter
Acromag 993EN-E0 £ e
=) Omron Corporation i — 2% Monitar,., ==
= ﬁ mmunicaliunsAdaplt & open...
= Usage Reset .
#d save as...
g | L n
< s -+ Upload
— — Reqister to other Device 3
* Message Code Date External Data » (V] erify
€ 156:0200 2010403705 10:28:57 i & cu ed.
Copy
¥ Delete

si--- @ Online

CAP

18. The Edit Device
Parameters window
should now appear as
seen here. Click OK.

19. The configuration
must now be
downloaded to the
PLC. Right click on the
PLC image, select
Parameter-
>Download.
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20. Click on Yes. MNetwork Configurator X

'E Downloading parameters to selected devices will start,
[

ke

21. Click on Download after
changed to Program

List of Device that are executing

Mode. The following devices are nat in program mode.
# Product Mame Cormment
@ 172164021 CIZB-EIP21
[ Diownload after changed to Program mode l [ Diownload with Current mode ] | Cancel |

22. Click on Yes. MNetwork Configurator X

i } Controller's mode will be returned to the state before starting download.
' ok

23. Click on OK. Metwork Configurator [‘5__<|

- | ) Download of device parameter was completed,
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Testing The
Configuration

Promne = == 1. You can test your
S vew PLC ook beb configuration by using

v | |l | & Ee o I L T4 i o o i 2 B 27 A
[|Dmn|m|@£ﬂae Blog|ahkew||ass|F|lii|esR|asrd] the CX-Programmer.
|axaal|ifsEmEr|srnww | —ooaaEL k|3 S ke %Y Start it by selecting
EERERmE | 2P EE 288 (%% B8 (S| asr mmMELw > Start->All Programs-

>0mron->Cx-One->
Cx-Programmer.
Click on File->New.

i

For Help, press F1 =01

2. Select CJ2H for the
Device Type and then

Change PLC
— Device Mame click its Settings

[NewPLLT button.

—Device Type

CIM ~|  Settings... |
~[CITH ~

EE:”:' Settings. .. |
CPMI[CPM14)

CPk2-

CPh 25

A COM1 bl

k. I Cancel Help |
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3. Select CPU66-EIP for the
CPU Type, this may differ
depending on which PLC
you have. Click OK.

4. Select View->Windows-
>Watch to bring up the
Watch window. Double
click on the first row to
bring up the Edit Dialog
box.

Device Type Settings [CJ2ZH]

General ]

CPU Type

|CPUB4-EIP |

CPUB4-EIP
TACPUES-EIP
CPLEE-EIP
CPUEY-EIP
CPUES-EIP
E =panzion Memany

| [

File Memory
| 1] L

Timer / Clock
[+

[ ReadOnly

[ Read Only

Make Default
| Q. |

Cancel | Help

e Untitled - CX-Programmer - [NewPLC1.NewProgram1.Section1 [Diagram]]
File Edit Wew Insert PLC Program Simulation Tools  window Help

O HE o & B 7N By, | Ty

&t 3
o B EE O

I — Y O

~

| | | | |\ sheet A shaatZ)\ sheelﬂf H 4

MEN [Program MName : NewProgrami ] a
= % MewProject s -
= E MewPLC 1[CI2H] OFfline [Section Mame : Section!]
=4 Symbols
7 [0 Table and Unkt Setup ooy :
Settings E ;
Gﬁ Memory = ¢ e
=8y programs [ e 7
= ‘a MewProgrami (00) f
= Symbols v [l D
PfDiEC[/ = Narne: Address or Yalue: mmenk:
2| pLC MName | Name Address | DataT... | FBUsage | Walue Walue(B...  Comment

For Help, press F1
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Edit dialog

PLLC: |

Mame or address:

|EDDd

Data Tupe £ Farmat: |EH.-’-‘-.NNEL [Hex.Channel]

IIIK|

Cancel |

e Untitled - CX-Programmer - [NewPLC1.NewProgram1.Section1 [Diagram]]

File Edit Wew Insert PLC Program Simulation Tools  window Help

% 2 8 &
Siz 1[E

B B O

O HE o

-8 x

= % MewProject A
= f@ MewRLC1[C12H] Offline
=4 Symbols
@7 [0 Table and Unit Setup

== o [Program MName : NewProgrami ]
[Section Mame : Section?]

1 N

N

| | | | |\ sheet A shaatZ)\ sheelﬂf H 4

NewPLCL 5000 CHAN...
I

Settings ;
Gﬁ Memory = ¢ e
=8y programs [ e 7
= ‘a MewProgrami (00) f
= Symbols v |l ‘ D
PfDiEC[/ = Narne: Address or Yalue: mmenk:
2| pLC MName | Name Address | DataT... | FBUsage | Walue Walue(B...  Comment

3

For Help, press F1

Edit dialog

FLC: |

Mame ar address: |51 on

[

Browse...

Data Type ¢ Format; |EH.-’-‘-.NNEL [Hexs. Channel]

(o]

El

Cancel |

3

5. Enter 5000, address of
the inputs, in the
Name or Address
field. Click OK.

6. Double click on the
second row now.

7. Enter 5100, address of
the outputs, in the
Name or Address
field. Click OK.
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8. You should now see both = Untitled - CX-Programmer - [NewPLC1.NewProgram{.Section [Diagram]] E”'E”z‘
the |nput and output tags File Edit Wiew Insert PLC Program  Simulation Tools Wwindow  Help - & x
in the Watch window. == & LS o, | &

8 E
CEERDE
% T " MEN [Program MName : NewProgrami ] a
= ewPrajed A =
= E MewPLC 1[CI2H] OFfline [Section Mame : Section!]
=4 Symbols
3 10 Table and Unit Setup ovecooercersesconees ;
Settings é ;
Gﬁ Memory 2 ¢ e
=% Programs Bvserssessoicricises 33
= ‘a MewProgrami (00) i
v | ’
= Name: Address or Yalue: mmenk:

Usage | Walue Walue(B...  Comment

DataT...

CHAMM,.,
CHARNM. .,

Address

5000
5100

PLC Mame | Mame

MewPLC1
MewPLC1

3

| | | |\ sheet A sheet2 )\ sheelﬂf H 4

For Help, press F1

9. You must now bring the = Untitled - CX-Programmer - [NewPLC1.NewProgram{.Section [Diagram]] E”'E”z‘
PLC 0n||ne' do th|s by r|ght File Edit Wew Insert PLC Program Simulation Tools  window Help -8 x
clicking on the PLC entry == & 2N &, | T
in the tree and selecting == kel
Work Online. If the PLC is o ERE DS
nOt n monltorlng mOde’ ME[ [Program Mame : MewProgrami] =
select PLC->Monitor- = NewProect = r

) ) = E MewPLC 1[CI2H] OFfline \ [Section Mame : Section!]
>Monitoring from the £2 Symbols
) 3 10 Table and Unit Setup orecocessersercesecry
main menu. Sattings
Gﬁ Memory 2 ¢ e
=% Programs % sorssesrel
] ‘a MewProgrami (00) Jj
= Symbols v |l ‘ D
PfDiEC[/ = Narne: Address or Yalue: mmenk:
2| pLC MName | Name Address | DataT... | FBUsage | Walue Walue(B...  Comment
MewPLC1 5000 CHAMM,.,
MNewPLCL 5100 CHAMM. ..

| | |\ sheet A sheet2 )\ sheelﬂf H 4 3

For Help, press F1
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e Untitled - CX-Programmer - [[Running] - NewPLC1.NewProgram1.Section1 [Diagram]]

File Edit Wew Insert PLC Program Simulation Tools ‘Window Help -
= = ] & 7 w2 &, | &
=rH ]
o B E 8
HEND [Program Mame : NewvPrograrm ] a
@ Memory card ~ =1
8 Error log [Section Mame : Sectiond]
PLC Clock —
G Memory s ”"
= % Programs
= @ MewProgram] (00) Running H “
= Symbols Sririericeisiiiiiiriee /’.
5 Sectiont x
5 END v [l L4
PfUiECl/{ =l Name: Address or Value: TArmenk:
ﬂ PLC Mame | Name Address | DataT...  FBUsage “alue ValuelB. .. | Comment
MewPLC1 s000 CHANM,.. OF00 Hex 0000 1.
MewPLC1 5100 CHAMNM, 0000 Hex 0000 0...
|
| | | [\ shest] A sheet? ,"\ sheelE/ H 1 3
For Help, press F1 MewPLCL - Run Mode 0.33ms |SYMNC

10. If your configuration is
correct, the watch
window will display
data being read and
sent to the Acromag
device. In this case, all
4 discrete 1/O
channels on port 3 of
a 983EN-6012 are
active so the input is
reading OxOF00 Hex.
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NOTES:
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